Поиск

 
Новости, Статьи
Форум
Файлы

Привет, Гость

Войти
Идентификация
Я забыл свой пароль
Регистрация

Для создания сайтов небольших фирм существует только одна бесплатная специализированная CMS на русском языке - ReloadCMS, которую активно развивает автор этого сайта.

РазделыНовостиПоследние новости → Формула расчёта Пасхи для Гугл таблиц

 

С сайта http://data.mooseum.ru/1-rubrika/kalendar/prazd-001-raschet_pasx.php

Алгоритм для вычисления даты православной Пасхи


Для определения даты православной Пасхи по старому стилю необходимо:

  1. Разделить номер года на 19 и определить остаток от деления a.
  2. Разделить номер года на 4 и определить остаток от деления b.
  3. Разделить номер года на 7 и определить остаток от деления c.
  4. Разделить сумму 19a + 15 на 30 и определить остаток d.
  5. Разделить сумму 2b + 4c + 6d + 6 на 7 и определить остаток e.
  6. Определить сумму f = d + e.
  7. Если f ≤ 9, то Пасха будет праздноваться (22+f) марта;
    если f > 9, то Пасха будет праздноваться (f-9) апреля.

Для перевода на новый стиль дату, как известно, нужно сдвинуть вперёд на 13 дней в 20-м и 21-м веках.
Православная пасха в 20-м и 21-м веках происходит в период с 4-го апреля по 8-е мая.

Если Пасха совпадает с праздником Благовещения (7 апреля), то она называется Кириопасха (Господня Пасха).

Теперь если всё это заделать в Гугл таблицы?

Получилась такая формула (год вводим в ячейку A2):

=ЕСЛИ($A$2>1899;ЕСЛИ((ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+ОСТАТ(2*ОСТАТ($A$2;4)+4*ОСТАТ($A$2;7)+6*ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+6;7))>9;ДАТА($A$2;4;ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+ОСТАТ(2*ОСТАТ($A$2;4)+4*ОСТАТ($A$2;7)+6*ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+6;7)-9+13);ДАТА($A$2;3;ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+ОСТАТ(2*ОСТАТ($A$2;4)+4*ОСТАТ($A$2;7)+6*ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+6;7)+22+13));ЕСЛИ((ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+ОСТАТ(2*ОСТАТ($A$2;4)+4*ОСТАТ($A$2;7)+6*ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+6;7))>9;ДАТА($A$2;4;ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+ОСТАТ(2*ОСТАТ($A$2;4)+4*ОСТАТ($A$2;7)+6*ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+6;7)-9);ДАТА($A$2;3;ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+ОСТАТ(2*ОСТАТ($A$2;4)+4*ОСТАТ($A$2;7)+6*ОСТАТ(19*ОСТАТ($A$2;19)+15;30)+6;7)+22)))

24.12.2021 18:15 Автор/источник: -

Комментировать

Вы не залогинены! Регистрация

Устал читать? Напиши! Или позвони +375 29 5344286. На связи по будним дням с 800 до 1700.